MinePeon auf dem Raspberry Pi (12.11.13)

Dieser Beitrag wurde 33409 mal angezeigt.

Hy Leute,MinePeonLogo

Ihr sucht nach einer Anleitung, wie ihr MinePeon auf euren Raspberry Pi betreiben könnt?

Hier nun die Anleitung dazu:

Schritt 1: Download von MinePeon

Als erstes braucht ihr einmal ein Image, das ihr auf eine SD Karte kopiert.
Dazu könnt ihr hier das letzte Image (Stand: 12.11.13) downloaden oder von der offiziellen Seite downloaden.

 

Schritt 2: Image auf SD Karte kopieren

Als nächstes müsst ihr das Image entpacken und auf eine SD Karte kopieren. Ich empfehle eine 4 oder 8 GB Karte. Für weitere Spielereien 😉
Dazu könnt ihr am besten das Programm Win32DiskImager benutzen. Einfache Handhabung, ohne Installation.

Win32_Disk_Imager_MinePeonIhr schließt euren Kartenleser an und steckt eure SD Karte rein und startet das Programm. Wählt das entpackte Image und das Laufwerk aus, und klickt auf “Write”. Das Image wird nun auf die Karte geschrieben.

Schritt 3: Raspberry starten

gpio_closeup

  • Nachdem die ISO-Datei auf die SD Karte geladen wurde, können wir diese in unseren Raspberry schieben.
  • Nun gibt es 2 Möglichkeiten:
    • Direkt starten und los minen ( wenn den schon richtig konfiguriert)
    • Per USB Debugger Kabel auf unseren Raspberry zugreifen und die entsprechenden Einstellungen vornehmen damit unser Miner ins WLan kommt und sich zu unserem Pool verbindet.

Wir verbinden unser USB Debugger Kabel also mit unserm PC. Dieser wird von Win7 direkt erkannt und ein entsprechender COM Port wird zugewiesen. Welcher COM Port gewählt wurde können wir unter “Geräte und Drucker” finden.

Nun besorgen wir uns das Programm “Putty” Download : putty

  • Nun starten wir Putty und geben die entsprechenden Daten ein damit wir uns zu unseren Paspberry verbinden können.
  • Wir setzen die Connection type auf: Serial
  • Speed auf 115200
  • Wer Putty vorher schon einmal verwendet hat, sollte darauf achten das ISO-8859-1 : 1998 (Latin-1, West Europe) eingestellt ist.
  • Anschließend klicken wir auf “Open”. Putty wartet nun auf eine Verbindung.

new_putty_connection_windowPutty_MinePeon  Putty_MinePeon_2

 

  • Zum Login: minepeon
  • Das Standard Passwort: peon
  • Nun rufen wir die Netzwerkeinstellungen auf wir benötigen nochmal das selbe Passwort, “peon” :
  • oder
  • Drücke Shift+P um in die Einstellungen zu kommen
  • Nun bist du bei “Wireless Interface!,  “wlan0” (Ohne die “)
  • Anschließend “F10” um die Einstellung zu speichern und Shift-R zum Suchen des LANs
    Putty_MinePeon_3
  • Wir stellen uns mit den Pfeiltasten auf das WLAN das wir benutzen wollen und drücken mit der Pfeiltaste nach “rechts” um in die Einstellungen zu kommen.
  • Auf der nächsten Seite machen wir ein “X” bei “Automatically connect to this network”
  • Und eben unser WLAN Passwort bei “Key” ein.
    800px-Settings
  • Durch drücken der F10 Taste speichern wir unsere Einstellungen und befinden uns wieder im Hauptmenü. Hier stellen wir uns wieder auf unser WLAN und drücken die Taste Shift+C um zu unserem Netzwerk zu connecten.
  • Shift + Q zum verlassen der Einstellungen.
  • Um nun herraus zu finden, welche IP Adresse unser Minepeon hat:

     

Herzlichen Glückwunsch, jetzt sind wir im WLAN und können über SSH und HTTPS weiter machen.

Bei mir liegt der Minepeon nun auf

Hier solltet ihr nun umgeht die Einstellungen ändern. Passwort, Donation usw.

Und die Miner-Pools die hinterlegt sind entfernen und eure einfügen.

 

Ihr solltet euch aufjedenfall noch per SSH auf eurem Pi anmelden um einmal ein Update des MinePeon zu machen.

Dazu:

 

 

Nachdem ihr dies alles gemacht habt, könnt ihr den Miner neu starten.

Viel Spass beim minen!

 

Dir hat die Anleitung gefallen? Ich würde mich über eine kleine Spende freuen 😉

BTC: 122aH1XgqetWJyfrdNcxd3kJY7DNaSrvMK

 

Tags: , , , , , ,

Über Sven

- Du hast Fragen? - Do you have a question? - Dir hat mein Beitrag geholfen? - If my articles helped you : - Spend me a Beer ;)

59 Responses zu “MinePeon auf dem Raspberry Pi (12.11.13)”

  1. Heinig 26. November 2013 at 22:50 #

    Wie kann ich unter minepeon mein Cgminer Updates ohne das ich es nochmal Komplet in irgend ein Pfad downloaden muss, und wie Compile ich das Cgminer unter minepeon mit der extra Option –bitfury enable
    Den ich habe ein relative neuen asic miner welcher erst 3.8.3 unterstütz wird, bitte um dringende Hilfe…..
    MfG Heinig

    • Sven 26. November 2013 at 23:04 #

      Hy,

      per Shell einloggen und dies ausführen:
      #cd /opt/minepeon/
      #sudo git pull
      #cd /opt/minepeon/http/
      #sudo git pull

      So bekommst den MinePeon auf den letzten funktionierenden Stand.
      Ohne # 😉

      Beste Grüße

      • Heinig 26. November 2013 at 23:39 #

        Danke sven für die schnelle Antwort!
        Hab ich gemacht, wird Dan von git nur die Repo minepeon geupdatet oder auch Cgminer. Da in der aktuellsten minepeon Version 0.2.4 nicht die Cgminer Version 3.8.3 enthalten ist, mein asic miner ist relative neu dadurch funktionierte die mit keiner Version davor.
        Bin schon am verzagen, nur jeder weitere Tag wo der miner aufn i7 läuft ist verschwendete Energie kosten.

        MfG heinig

        • Sven 26. November 2013 at 23:46 #

          HY,

          MinePeon benutzt eine eigene CGMiner oder BfgMiner Version.
          Du kannst allerdings versuchen von git dir die letzte Version des CGMiners zu laden und selbst zu kompilieren.

          git clone
          oder per wget von der original Seite.

          • Heinig 26. November 2013 at 23:48 #

            Hm ok ;(

  2. Hendrik 7. Dezember 2013 at 15:36 #

    Hallo Heinig, hallo Sven,
    ich stehe vor dem gleichen Problem, ich bekomme einen neuen RedFury auf dem rPi einfach nicht zum Laufen. Habt ihr das schon hinbekommen? Wenn ja mit welchen Versionen von Minepeon, cgminer oder anderen? Danke für Eure Tipps,
    VG Hendrik

    • Sven 8. Dezember 2013 at 02:35 #

      Hy,

      ich hab leider kein Redfury. Daher kann ich es nicht testen…

      Beste Grüße,
      Sven

  3. e-raser 1. Januar 2014 at 00:19 #

    Hallo,

    hier mit einem BF1 (Blue Fury V2 – 2,6Gh/s) unter minepeon. Hat es von euch schon jemand geschafft einen solchen bzw. dieser “neueren” ASICs zum Laufen zu bekommen? Sven? Hendrik? Heinig?

  4. Sandro 4. Januar 2014 at 23:14 #

    Hallo,

    wie kann ich minepeon auf cgminer umstellen. Bei mir läuft standartmäßig die Version bfgminer 3.8.0.

    Gruß Sandro

    • Sven 5. Januar 2014 at 00:26 #

      Hallo Sandro,

      ja, das kann man. Unter Settings kann man dies einstellen.

      Beste Grüße

  5. Mario 13. Januar 2014 at 00:34 #

    Hallo alle zusammen,
    ertmal ein dickes Lob hier.
    Ich bin totaler neuling in sachen Linux & Co. aber Dank Euch läuft mein Pi mit Minepeon.
    Nur 2 Dinge versteh ich nicht richtig.

    1. Mein Antminer U1 Stick hat immer so um die 37% Errors mit bfgminer3.9.0, also wollte ich mal cgminer Benutzen aber…

    2. cgminer sagt mir immer “no devices” irgendwie findet er den Antminer U1 Stick nicht.
    Bin für jeden Tip dankbar…

    Beste Grüße Mario

    • Sven 13. Januar 2014 at 22:03 #

      Moin,

      dafür musst du den CGMiner neu kompilieren, da er aktuell noch nicht von minepeon direkt unterstützt wird.

      Beste Grüße

      • Mario 14. Januar 2014 at 00:15 #

        Aha,

        hättest du für mich eine Anleitung wie das geht? Wie gesagt, ich bin absoluter neuling mit Linux.

        Beste Grüße

        • Sven 14. Januar 2014 at 01:19 #

          Die Anleitung findest du unter dem Raspberry und Antminer.

          Damit sollte es gehen.

          Wenn du es nicht hin bekommst, kann dir gerne ein Image zusammen bauen.
          Darfst dich gerne per Kontaktformular bei mir melden.

          Beste

          • Mario 14. Januar 2014 at 01:35 #

            Hallo Sven,

            könnte denn der cgminer besser laufen als der bfgminer bezüglich der Errors? Oder ist das eher Hardware abhängig?

            Grüße und Danke

  6. Entei 16. Januar 2014 at 15:12 #

    Danke für dieses tolle how2

    leider habe ich folgendes Problem:
    Raspberri Pi Model B

    Im Minepeon wird mir eine MH/s rate von: 4589.424 (4,6GH/s) angezeigt.
    In meinem Pool (btcguild.com) jedoch deutlich weniger (3,7GH/s), was ist da los?
    wird da irgendwie illegal ein teil der Hashrate ohne das wissen des Nutzer abgezweigt?

    Version:
    MinePeon 0.2.4.3
    Miner Versionbfgminer3.9.0

    2x AntMiner U1 @2GH/s
    +
    2x ASIC Miner Block Erupter @0,3GH/s

    Zudem ist unter Setting Donate auch deaktiviert.

    • Sven 16. Januar 2014 at 20:20 #

      Moin,

      wenn Donate abgestellt ist, sollte die Hashrate im Pool landen, ausser es sind mehrere Pools hinterlegt.
      Allerdings wird die Hashrate bei BTCGuild anhand der Shares an den Pool ermittelt, die auf dem Pi anhand der Hardware.
      Somit kann es schon zu unterschieden kommen.
      Zudem kann es sein, das bei dir auf dem Pi die durchschnittliche Geschwindigkeit angezeigt wird. Einfach beobachten. Wenns wirklich immer so ist, solltest du mal weiter prüfen.

  7. Katrin 19. Januar 2014 at 21:07 #

    Hallo,

    ich habe wie weiter oben geschrieben das gleiche Problem am Raspberry mit minepeon und bfgminer, das meine 2 Antminer U1 1,6GH/s nur mit ca. 1.2GH/s laufen und das mit ca.36% Errors. Habe schon viel gegoogelt und probiert….komme aber nicht voran. Entweder das Ergebnis ist das gleiche mit 1,2 GH/s oder meine U1 Sticks werden erst gar nicht mehr erkannt. “no devices”
    Bitte wer kann mir helfen ? Und Bitte wenn möglich Schritt für Schritt erklärt.
    Supi.
    Dankeschön. 😉

    • Katrin 21. Januar 2014 at 11:34 #

      Hat keiner eine idee / Lösung?

      Grüße
      Katrin

      • Sven 21. Januar 2014 at 19:55 #

        Moin Katrin,

        Mal ein Update vom Minepeon machen. Wenn das noch nicht hilft, CGMiner oder BFGMiner manuell laden und kompilieren. Diesen dann über die Settings starten lassen.
        Dann klappt es.

        Beste Grüße,
        Sven

        • Katrin 21. Januar 2014 at 23:44 #

          Hey Sven.
          Danke, das Update hat was gebracht. Die Errors liegen jetzt bei 1-5%. 🙂

          Nun hab ich nur noch ein einziges großes Problem.
          Um das ganze stabiler zu machen will ich watchdog installieren. Aber denkste… sobald ich den Befehl apt-get… oder apt-cache…. usw. verwenden will kommt nur eine Fehlermeldung: command not found. Nicht mal meinen WLan Stick Edimax kann ich so Installieren. hab schon 2x das Image neu aufgespielt. Ohne Erfolg. Google sagt mir auch nur das ich das Paket apt installieren soll…., aber woher und wie …kein Plan.
          Bitte helft mir noch ein letztes mal….
          Bitte Bitte Bitte…. 🙁

          ganz liebe Grüße,
          Katrin

          • Sven 22. Januar 2014 at 00:51 #

            Auf Minepeon gibt es kein apt.

            Somit bleibt dir nur mit pacman zu arbeiten. 😉

  8. Katrin 22. Januar 2014 at 11:28 #

    Hi,

    Mit pacman habe ich noch nie gearbeitet. Wie genau installiere ich denn dann den watchdog mit pacman?

    Liebe Grüße

    Katrin

    • Katrin 23. Januar 2014 at 15:33 #

      Soooo…

      habe jetzt folgendes gemacht um den watchdog in minepeon zu installieren:

      $ echo “bcm2708_wdog” | sudo tee /etc/modules-load.d/bcm2708_wdog.conf

      $ sudo pacman -S watchdog

      $ sudo systemctl enable watchdog

      $ sudo nano /etc/watchdog.conf

      $ sudo modprobe bcm2708_wdog; sudo systemctl start watchdog.service

      zumindest ist er schonmal gestartet.
      Hoffe das es so richtig ist und funktioniert.

      LG Katrin 😉

  9. Jörn 31. Januar 2014 at 17:25 #

    Das Wlan-Setup wurde geändert: Statt mit “sudo wicd-curses” geht es in meiner Version (MinePeon Pi 0.2.5 pr1) mit “sudo wifi-menu”.

    • David 14. Februar 2014 at 00:55 #

      merkt er sich die Einstellungen nach einem Reboot?

  10. roy 9. Februar 2014 at 20:26 #

    Hallo Sven,

    ich habe en Problem bei der Einrichtung des WLAN: wenn ich den screen aufrufen will kommt “screen is terminating”
    ich habe auch versucht, das wlan so einzurichten, wie n dieser Beschreibung http://minepeon.com/index.php/WiFi
    aber wenn ich eingebe sudo wicd-curses kommt als antwort “comman not found”, gebe ich ein sudo apt-get install wicd (oder auch dasselbe mit “wicd-surses”), kommt wieder nur “command not found”
    Hast Du eine Idee, wie ich da vorgehen kann?

    • Sven 11. Februar 2014 at 01:09 #

      Lan Einstellungen haben sich geändert. Siehe Kommentare 😉

      sudo wifi-menu

      Beste Grüße

      • David 14. Februar 2014 at 00:51 #

        Hab das selbe Problem… allerdings
        – mit sudo wifi-menu alles einstellen -> schick, geht
        – reboot…. Wifi wieder inaktiv ( Einstellungen sind aber noch in wifi-menu drin)

        – 0.2.5 PR1 und PR2

        – bei welcher hat es noch gespielt??

        Dankend der dave

  11. thomas 10. Februar 2014 at 20:25 #

    hallo!

    ich habe einen neuen raspberry pi und bekomme minepeon leider nicht ans laufen… Icon_skeptisch

    folgendermaßen bin ich vorgegangen:
    – minepeon-image mit win32Diskimager auf die sd-karte kopiert (erfolgreich)
    – den raspberry per kabel ans netz(werk) gehangen
    – sd-karte eingelegt und raspberry gestartet

    leider bootet das system nicht bzw. bekomme ich kein signal auf den monitor!

    ich habe bereits zwei sd-karten und auch drei versionen von minepeon ausprobiert.

    mit einer anderen sd-karte mit raspbian läuft der pi einwandfrei…. (auch die internetverbindung per kabel)

    jemand eine idee was da schief läuft?

    muss ich noch vorab auf dem image auf der karte was konfigurieren?

    btw: nach ca 15-20 sec leuchten alle leds dauerhaft. nur die grüne neben der gelben blinkt ab u zu….

    ich hoffe jemand hat einen tipp…

    viele grüße

    • thomas 12. Februar 2014 at 21:47 #

      hat sich erledigt! 🙂 der monitor war defekt bzw minepeon konnte den monitor nicht hochfahren…

  12. Sebastian 28. Februar 2014 at 18:12 #

    Hallo Sven,
    Hast du ggf. auch mal eine Anleitung, die mit der aktuellen Minepeon 0.2.4
    das Thema Update CGminer für die Verwendung der Technobit HEx16a+ Hex16A2 sowie Hex16B Chipsets berücksichtigt ?
    bei der Minepeon 0.2.4 hat sich leider die Filestrucktur geändert, so dass dein altes AntMiner Howto nicht funktioniert, da die Verzeichnisse so nichtmehr existieren.

    Wünschenwert wäre ein Minepeon
    – mit gepatchtem CGMiner für Technobit Boards (am besten CGMiner 4.0)

    – USB LCD Screen Support (https://github.com/cardcomm/cgminerLCDStats)
    hier dann am besten auch geupdated mit einem Feed von Bitcoin statt Mt Gox

    – Watchdog, MobileMiner oder PiMiner

    gerne helfe ich auch mit dem testen 🙂

    Grüße aus Bochum
    der Sebastian

  13. marcelo 6. Juni 2014 at 20:36 #

    hallo!

    bis jetzt alles ok, nun meine frage brauche ich unbedingt ein usb debug kabel oder gibts einen anderen weg auf meinen pi zuzugreifen

    • Sven 6. Juni 2014 at 23:21 #

      Moin,

      es gibt noch die Möglichkeit übers Netzwerk. Aber nur wenn das Image so eingestellt ist, das es sich automatisch den DHCP sucht und sich eine IP Adresse zuweisen lässt.
      Dann musst du diesen nur noch im LAN finden und per SSH drauf zu greifen.

      Ein Debug Kabel sollte aber bei jedem Pi Pflicht sein. Den nur so kannst du ggf. raus bekommen warum dein Pi stehen geblieben ist oder warum er sich nicht mehr Booten lässt.

      Beste Grüße,
      Sven

  14. Daniel 28. Juni 2014 at 22:31 #

    Hi Sven,

    ich möchte an einem rPI unterschiedliche miner verwenden, z.b. einen bzw. mehrere R-BOX (rockminer), mindestens einen ZEUS blizzard und verschiedene USB-Stick-Miner.

    frage 1:
    ist das überhaupt möglich?

    frage 2:
    kann ich an einen aktiven usb hub mehrere aktive usb hubs anschließen, bzw kann das der rPi verwalten?

    frage 3:
    die zeus miner werden erst ab bfgminer 4.2.1 unterstützt, gibt es dieses version überhaupt für den rPi?

    frage 4:
    nicht zum thema aber…
    du hast ja auch einen rockminer, läuft dieser bei dir sabil oder musst du den miner auch mindestens einmal am tag neustarten? läuft bei mir mit bfgminer 4.2.0..

    vielen dank und viele grüße
    daniel

    • Sven 29. Juni 2014 at 19:45 #

      Hallo Daniel,

      Wenn der Miner z.b. BFGMiner oder CGMiner die komplette Hardware unterstützt, kann man diese global für alle nutzen.
      Wenn die Software dies nicht macht, wird es schwierig.
      Frage 1:
      Wenn man mehrere Instanzen laufen lässt ,muss man diesen die USB Ports zuweisen. Sonst werden die anderen durch eine Instanz blockiert.
      Frage 2: Am Rapsberry Pi kann man meiner Erfahrung nach max 2 Hubs hintereinander nutzen. Alles weitere wird nicht erkannt.
      Frage 3: Soweit ich weiß kann man Script und SHA256 Miner nicht parallel mit einem Miner nutzen. Versuch mal ein CGMiner parallel laufen zu lassen
      Frage 4: Mein RockMiner hat leider den Geist aufgegeben. Ich bekomme nur noch USB Fehler.
      Hotplug: Rockminer added AMU 0
      AMU 0 GetResults usb read err:(-9) LIBUSB_ERROR_PIPE
      AMU 0 attempted reset got err:(-5) LIBUSB_ERROR_NOT_FOUND
      AMU0: Comms error (rerr=-5 amt=0)

      Das kann mehrere Gründe haben. Von “einfach Defekt” Bis zu der Miner bekommt zu wenig Strom, weil das Netzteil nicht mehr genügend Power bringt.
      Das muss ich jetzt erstmal raus bekommen.

      Beste Grüße

      • Sven 30. Juni 2014 at 19:46 #

        Hat sich erledigt. Lag am Netzteil…. Das hat den Geist aufgegeben. Neues Netzteil dran mit 12V 6A und alles läuft wieder. 😉

      • Daniel 30. Juni 2014 at 22:04 #

        Hi Sven,

        also im windows habe ich zurzeit 4 bfgminer gleichzeitig laufen. drei davon an einem btc pool und einen an einem ltc pool. also unter windows ist das zumindest kein problem mehrere miner parallel laufen zu lassen.
        die usb-ports muss ich auch nicht zuweisen, zumindest beim bfgminer. cgminer habe ich noch nie verwendet.

        meinen rasberryPI habe ich noch nicht, diesen bekomme ich erst zusammen mit meinem neuen zeus miner. würde aber gerne im vorfeld wissen ob ich, wie im windows, mehrer instanzen vom bfgminer im minepeon ausführen kann, oder eben nur eine 🙂

        läuft/lief denn dein rockminer stabil?
        ich muss meinen mindestens einmal am tag neu starten, egal ob übertaktet oder nicht.
        meine blockeruper, antminer und der scrypt miner von zeus laufen hingegen einwandfrei, auch übertaktet.

        falls deiner stabil läuft muss ich wohl doch mal cgminer testen.

        viele grüße

        • Sven 1. Juli 2014 at 23:08 #

          Hy,

          wie gesagt, auf dem Raspberry geht das prinzipiell auch, nur muss man hier dann angeben, welche Ports man nutzen will, da diese sonst blockiert sind.
          Der CGMiner läuft in der Version, die ich in meinem Tutorium verwende komplett stabil. Der CGMiner läuft dem erst mal konfigurieren tadellos.

          Nur das Netzteil hat in der Zeit einmal den Geist aufgegeben. Daher habe ich nun ein 12V 6A Netzteil angeschlossen.

          Beste Grüße,

  15. Mart 26. Juli 2014 at 10:13 #

    Hallo,
    ich habe gestern meinen Pi mir Minepeon drauf bekommen. Ich hab eine R Box drann gehangen, hab alles gleich angeschlossen, w lan eingerichtet alles upgedatet. Aber er erkkent meine R Box nicht, er sagt immer No devices… warum? 🙁 und was kann ich dagegen tun? ich weiß nicht mehr weiter. Hatte wer das selbe problem?

  16. Mart 1. August 2014 at 19:46 #

    Keiner ne Idee?

  17. Tom 5. August 2014 at 13:43 #

    Hi Mart,
    genau dieses Problem hab ich gerade auch 🙂
    R Box dran gehängt, wird nicht erkannt 🙁

  18. Mart 7. August 2014 at 08:39 #

    Hallo,
    Damit wurde er bei mir erkannt.
    Vllt klappt’s ja bei dir!
    https://www.youtube.com/watch?v=C6ir0QpgSzs

  19. Yekta 7. Dezember 2014 at 19:31 #

    Hallo Sven,
    ich habe mir vor kurzer Zeit einen Raspberry Pi B+ zugellegt mit allem drum und dran.
    Nun wollte ich diesen zu einem Bitcoin-Miner umfunktionieren, also habe ich Minepeon-0.2.4.6 Drauf gezogen.
    Ich habe es mit einem Lan Kabel und Wlan Stick funktioniert. Nichts vom beiden erkennt der. Habe deine Anleitung befolgt aber der findet einfach keine Netzwerke. Für gewöhnlicherweise fängt mein Wlan-Stick blau an zu Blinken sobald der eingesteckt ist. Bei dem neuen Image (Minepeon) tut der dies nicht mehr. Als ich unter “Use Static IPs” bei “IP:” meine IP von meinem Router eingegeben habe stand da “Connected to wired network (IP meines routers)” Aber trotzdem habe ich keine Verbindung… was kann ich machen?

    • Sven 8. Dezember 2014 at 19:40 #

      Hy,

      wird dein Stick vom Raspberry erkannt? Oder ehr, vom Betriebssystem? Probiere mal Raspbian aus, wenn dieser den erkennt, sollte es gehen.
      Wenn dieser dort auch nicht erkannt wird, kann es sein, das der Stick hinüber ist oder nicht kompatible ist.

      • Yekta 10. Dezember 2014 at 09:59 #

        auf raspian funktioniert alles. der stick funktioniert überall nur nicht auf minepeon

        • limomann 15. März 2015 at 21:42 #

          mittlerweile gibt es ein image für den b+ Minepeon-0.2.4.6-B.plus.nc….
          aber ich komm damit noch nicht so klar entweder mach ich irgendwo nen fehler und meine hubs sind dafür nicht vorgesehn…

  20. simon 20. Dezember 2014 at 00:36 #

    hey
    mein raspberry pi b plus erkennt keine tastatur und maus was soll ich tun??? und außerdem macht er kein ssh.und die led am ethernet imput also da wo die kabel sind leuchten nicht also erkennt er auch kein internet kabel.wäre nett wenn du mir helfen könntest

  21. Luca 11. Januar 2015 at 11:58 #

    Hab das selbe Problem 🙁 alle Anschlüsse funktionieren nicht mit der neusten minepeon version. Hätte da wer ne Lösung ? Danke schon mal im Voraus. 🙂

  22. Dennis 4. März 2015 at 13:18 #

    MinePeon funktioniert mit B+ noch nicht. ein akuelles image ist gerade in arbeit, im minepeon forum ist ein entsprechender eintrag (es gibt wohl ne art beta)

  23. Gerdi 1. September 2015 at 18:05 #

    Gibt es noch ein Image, das (zu Testzwecken) noch ganz ohne ASIC funktioniert ?
    ( also nur mit dem RPI – Prozessor ?)
    Erhalte bei git pull auch immer error: bin/bitstreams/README , finde aber kein bitstreams)

    • Sven 2. September 2015 at 00:36 #

      Einfach ein Raspbian Image nehmen 😉

  24. Carsten 4. Februar 2016 at 20:26 #

    hallo habe einen pi2 b bekomme aber minepeon nicht zum laufen, es bootet nicht, bildschirm sagt kein signal, lankabel connect status led leuchtet am router nicht also kein lanzugriff, habe das minepeon für pi 2 b+ im internet gefunden und getestet, da bootet er nur bis zu so einem bunten bildschirm, kein login, habt ihr schon ein lauffähiges minepeon für den raspberry pi 2 b?

    • Sven 5. Februar 2016 at 17:11 #

      Hallo Carsten,

      Minepeon läuft auf Port 80. Soweit ich weiß, gibt es keine Display Ausgabe.

      • Carsten 5. Februar 2016 at 18:12 #

        ich komm aber nicht einmal zum login hab sämtliche minepeon versionen ausprobiert die einzige die halbwegs gebootet is war eben die b+ version aber da komm ich auch nicht zum login nur der bunte bildschirm und ethernetverbindung bekommt er auch nicht also auch keine up zugeordnet wo ich mit putty darauf zugreifen könnte.

  25. Carsten 9. Februar 2016 at 18:54 #

    hallo hab mir jetzt ein debuggkabel gekauft verbindung wird zum pi durch putty aufgebaut jedoch zeigt mir putty nichts an.

  26. alex 25. Juni 2016 at 13:36 #

    hy sven,
    ich hatte vor ein paar tagen schon einmal gemailt. ich bekomme meinen Antminer U3 per RaspPi B+ nicht zum laufen. ich will, wollte minepeon installieren, dann den cgminer updaten uswusw. deiner anleitung nach bin ich vorgegangen, raspian drauf, dann per win32diskimg. das minepeon-img drauf und daaannn, nix. ich hab nen monitor und ne tastatur am Pi angeschlossen, wo auch der minepeon log in abgerufen wird, aber ich kann keine eingabe machen. meine tastaur geht nicht mehr. vorher, ohne minepeon, nur mit raspian hat sie funktioniert. ich bin absoluter linux-unerfahren, auch mit dem Rasp Pi neu, habs auch schon mit nem usb-hub mit eigener stromversorgung versucht. kann aber keinerlei eingabe machen, somit keine ip abfragen. ich vermute einen fehler gemacht zu haben, komm aber nicht drauf welcher.

    • Sven 7. Juli 2016 at 10:02 #

      Hy,

      minepeon hat keine HDMI Ausgabe. Man muss mit dem Browser drauf gehen. Da hat man dann auch alle Einstellungsmöglichkeiten.

      Wenn Interesse besteht, ich habe noch ein 400GH HEX Miner günstig abzugeben.

Schreibe einen Kommentar

Blog Archiv